domingo, 22 de agosto de 2010

Práctica de EIGRP y OSPF

En el capítulo 7 del Sybex para CCNA tenemos una práctica de laboratorio para EIGRP y OSPF que cubre la siguiente topología, y después un ejemplo de como se lleva a cabo la elección de un Designated Router cambiando las prioridades de los routers para forzar las decisiones hacia nuestro interés.


EIGRP y OSPF

Ejemplo en Packet Tracer.

Para la primera topología:

TABLa 7 . 5 Esquema de direccionamiento IP
router Interface IP address
A F0/0 172.16.10.1
B E0 172.16.10.2
B S0 172.16.20.1
C E0 172.16.30.1
C S0 172.16.20.2
C S1 172.16.40.1
D S0 172.16.40.2
D E0 172.16.50.1



Hands-on Lab 7.1: Configuring and Verifying EIGRP
1. Implement EIGRP on A:
A#conf t
Enter configuration commands, one per line.
End with CNTL/Z.
A(config)#router eigrp 100
A(config-router)#network 172.16.0.0
A(config-router)#^Z
A#
2. Implement EIGRP on B:
B#conf t
Enter configuration commands, one per line.
End with CNTL/Z.
B(config)#router eigrp 100
B(config-router)#network 172.16.0.0
B(config-router)#exit
B#
3. Implement EIGRP on C:
C#conf t
Enter configuration commands, one per line.
End with CNTL/Z.
C(config)#router eigrp 100
C(config-router)#network 172.16.0.0
C(config-router)#^Z
C#
4. Implement EIGRP on D:
D#conf t
Enter configuration commands, one per line.
End with CNTL/Z.
D(config)#router eigrp 100
D(config-router)#network 172.16.0.0
D(config-router)#^Z
D#
5. Display the topology table for C:
C#show ip eigrp topology
6. Display the routing table on the C router:
C#show ip route
7. Display the neighbor table on the C router:
C#show ip eigrp neighbor

Hands-on Lab 7.2: Enabling the OSPF Process
1. Enable OSPF process 100 on A:
A#conf t
Enter configuration commands, one per line.
End with CNTL/Z.
A(config)#router ospf 100
A(config-router)#^Z
2. Enable OSPF process 101 on B:
B#conf t
Enter configuration commands, one per line.
End with CNTL/Z.
B(config)#router ospf 101
B(config-router)#^Z
Hands-on Labs 481
3. Enable OSPF process 102 on C:
C#conf t
Enter configuration commands, one per line.
End with CNTL/Z.
C(config)#router ospf 102
C(config-router)#^Z
4. Enable OSPF process 103 on D:
D#conf t
Enter configuration commands, one per line.
End with CNTL/Z.
Router(config)#router ospf 103
D(config-router)#^Z

Hands-on Lab 7.3: Configuring OSPF Neighbors
1. Configure the network between A and B. Assign it to area 0:
A#conf t
Enter configuration commands, one per line.
End with CNTL/Z.
A(config)#router ospf 100
A(config-router)#network 172.16.10.1 0.0.0.0 area 0
A(config-router)#^Z
A#
2. Configure the networks on the B router. Assign them to area 0:
B#conf t
Enter configuration commands, one per line.
End with CNTL/Z.
B(config)#router ospf 101
B(config-router)#network 172.16.10.2 0.0.0.0 area 0
B(config-router)#network 172.16.20.1 0.0.0.0 area 0
B(config-router)#^Z
B#
3. Configure the networks on the C router. Assign them to area 0:
C#conf t
Enter configuration commands, one per line.
End with CNTL/Z.
C(config)#router ospf 102
C(config-router)#network 172.16.20.2 0.0.0.0 area 0
C(config-router)#network 172.16.30.1 0.0.0.0 area 0
(config-router)#network 172.16.40.1 0.0.0.0 area 0
C(config-router)#^Z
C#
4. Configure the networks on the D router. Assign them to area 0:
D#conf t
Enter configuration commands, one per line.
End with CNTL/Z.
D(config)#router ospf 103
D(config-router)#network 172.16.40.2 0.0.0.0 area 0
D(config-router)#network 172.16.50.1 0.0.0.0 area 0
D(config-router)#^Z
D#
Hands-on Lab 7.4: Verifying OSPF Operation
1. Execute a show ip ospf neighbors command from the 2621 router and view the results:
A#sho ip ospf neig
2. Execute a show ip route command to verify that all other routers are learning all routes:
A#sho ip route

Para la segunda topología:
Conectamos todos los routers en una red de Broadcast (con un switch y los fastethernet) y les asignamos un esquema de direccionamiento, en este caso les asigné la red 10.1.1.0 /29 lo que nos deja un espacio de 8 direcciones IP: una de red 10.1.1.0, 6 utilizables 10.1.1.1 a 10.1.1.6 y una de broadcast 10.1.1.7.
Configuramos OSPF en todos los routers y la red que estamos utilizando:

>enable
#configure terminal
(config)#router OSPF 100
(config-router)#network 10.1.1.0 0.0.0.7 area 0
(config-router)#interface fa0/1
(config-if)#no shutdown
(config-if)#ip address 10.1.1.1 255.255.255.248  (en el primer router)
(config-if)#ip address 10.1.1.3 255.255.255.248 (segundo router)
(config-if)#ip address 10.1.1.6 255.255.255.248 (tercer router)

Y verificamos el status con el comando show ip ospf interface fa0/1 en los 3 routers. Veremos que el 3o es el que tiene la IP más alta, por tanto es nombrado el Designated Router.

Activamos los debugs para observar el cambio y procedemos con los cambios de prioridad:
#debug ip ospf adjacency
y vamos al 3e router en la interface fa0/1:
(config-if)#ip ospf priority 0
(config-if)#shutdown
(config-if)#no shut

Y observamos como tiene lugar el cambio de designated router.

Al cambiar la prioridad a 0 no puede participar en el proceso, por lo que el siguiente router con la IP más alta tomará su lugar, pero es importante dar de baja la interface para que el proceso de OSPF renueve el status de las rutas, y los nuevos Hello packets (dirigidos a la 224.0.0.5 en OSPF y a la 224.0.0.10 en EIGRP) establezcan nuevamente las adjacencias y se designe un nuevo DR.

No hay comentarios. :

Publicar un comentario